Intermittent HTTP 5xx Errors Returned by US Street API and US Zip Code API

Incident Report for Smarty

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 15:35 UTC

Monitoring

During a routine data deployment, we noticed a brief spike in 5xx error responses. Systems have since stabilized, and we're investigating the root cause to confirm the issue is fully resolved and to prevent similar behavior in future deployments.
Posted Oct 30, 2025 - 22:36 UTC
This incident affected: US Street [Address] API (US East 1, US West 1, US Central 1) and US ZIP Code API (US East 1, US West 1, US Central 1).