US Street API returning 503 response codes

Incident Report for Smarty

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 00:34 UTC

Update

The rollout is complete. We are continuing to monitor.
Posted Jul 21, 2026 - 23:10 UTC

Monitoring

A fix has been implemented and is rolling out to the fleet. We are monitoring the results.
Posted Jul 21, 2026 - 22:56 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 21, 2026 - 22:33 UTC

Identified

Starting from 19:00 UTC, unexpected input is resulting in a small percentage of requests returning 503 response codes from the US Street Address API. Resolution is currently underway, and an update will be posted to this page when it is complete.
Posted Jul 21, 2026 - 22:30 UTC
This incident affected: US Street [Address] API (US East 1, US West 1, US Central 1, US South 1).