Intermittent 503 Errors for US Street [Address] API

Incident Report for Smarty

Resolved

The issue has been resolved.

A small number of nodes experienced large memory consumption which resulted in a few 503 errors being returned. This has been resolved and measures have been put in place to mitigate this in the future. Additional alerts and monitors have also been put in place.
Posted Mar 10, 2026 - 15:58 UTC

Monitoring

The issue has been identified and we are currently monitoring overall system health.
Posted Mar 06, 2026 - 21:16 UTC

Investigating

We are currently investigating an increase in 503 Service Unavailable errors. We will provide an update as soon as more information is available.
Posted Mar 06, 2026 - 17:59 UTC
This incident affected: US Street [Address] API (US East 1, US West 1, US Central 1, US South 1).